Joe D.
Private
Posts: 25
Joined: Sat Jun 02, 2007 2:52 pm
Location: Stratford, CT, USA
Contact: Website

Strategy First game

Mon Jul 14, 2008 6:34 pm

I just bought the Strategy First version of Great Invasions -- I assume I should only patch-up to 1.07 as the patches after that are only for the AGEOD version?

User avatar
calvinus
Posts: 4679
Joined: Mon Dec 19, 2005 4:52 pm
Location: Italy
Contact: Website

Mon Jul 14, 2008 6:54 pm

If you can give proof of your purchase, send Philippe a PM and he will reply to you with the key for activating the 1.07c patch.

Joe D.
Private
Posts: 25
Joined: Sat Jun 02, 2007 2:52 pm
Location: Stratford, CT, USA
Contact: Website

Mon Jul 14, 2008 7:07 pm

calvinus wrote:If you can give proof of your purchase, send Philippe a PM and he will reply to you with the key for activating the 1.07c patch.


OK, I sent Phillip a PM, but I don't think I need 1.07c or even b, just 1.07 as my game was bought through Strategy First, not through AGEOD.

As I have dial-up, a physical copy is a must for me.

User avatar
Rafiki
Posts: 5811
Joined: Thu Aug 24, 2006 9:19 am
Location: Oslo, Norway

Mon Jul 14, 2008 7:34 pm

Joe, it's generally recommended that you upgrade to the latest patch available. The PM to Philippe is worth your while :)
[CENTER]Latest patches: AACW :: NCP :: WIA :: ROP :: RUS :: PON :: AJE
Visit AGEWiki - your increasingly comprehensive source for information about AGE games
[SIGPIC][/SIGPIC]
[/CENTER]

Joe D.
Private
Posts: 25
Joined: Sat Jun 02, 2007 2:52 pm
Location: Stratford, CT, USA
Contact: Website

Thu Jul 17, 2008 5:35 pm

OK, it's done: I'm at 1.07c. Thanks for the encouragement.

Return to “Great Invasions”

Who is online

Users browsing this forum: No registered users and 1 guest