Ekaton
Private
Posts: 33
Joined: Tue Oct 29, 2013 10:39 pm

Game-breaking error

Sat Feb 24, 2018 7:09 pm

I've started a hotseat campaign with my friends - 1850 campaign, all countries except for Belgium are played by us. It's our second attempt to do that, the game always breaks after a few turns. It shows an error, and then proceeds to calculate AI for every single country possible, most of which are not there at all - like Californian Republic or Bohemia-Moravia. The scenario is standard, without any modifications, no console commands have been used.

7:01:36 PM (Reporting) TMain, CreateForm OK
7:01:36 PM (Reporting) Application.Run Starting app...
7:01:36 PM (Reporting) Game Engine version: PON 1.04.5 June 19th, 2017
7:01:36 PM (Reporting) TGameSim.OnLoadGame_FilePicked C:\Users\Documents\My Games\Pride of Nations\VGN\Saves\1850 GC0\1850 GC~GBR.trn :Turn file loaded, # of entries: 658990
7:01:36 PM (Reporting) 1850 - Grand Campaign 1850, Early March (T: 2405) loaded
7:01:36 PM (Reporting) Gamesim data (excluding DBs) loaded in: 15256 ms
7:01:36 PM (Reporting) TSlaveThing.SetBitmap: Unable to find MediaInfo for image: Counter_TCH
7:01:36 PM (Reporting) Starting Hosting Phase Turn 4 272987 kb
7:01:36 PM (Reporting) 1850 - Grand Campaign 1850, Early March (T: 2405) loaded
7:01:36 PM (Reporting) Gamesim data (excluding DBs) loaded in: 15008 ms
7:01:36 PM (Reporting) Host: Starting AIs.
7:05:58 PM [Critical ] TGroup.PathExists Exception caught: 1011942 Burmese Army LogStep: 50 Access violation at address 00813967 in module 'PON.exe'. Read of address 0000045A


The log mentions the Burmese Army problem.

I can't attach the save game file - it says that the file is too large.

User avatar
Durk
Posts: 2514
Joined: Thu Apr 28, 2011 4:36 am
Location: Wyoming

Re: Game-breaking error

Sun Feb 25, 2018 12:06 am

Watching the game making AI decision for countries and faction when running the turn is normal. If a faction can appear in the game, even if not present, this is a way of maintaining all factions, such as the Bear Republic, until they enter the game.

There are two very likely reasons for the game breaking. The most probably is that all players are not in the same version. Make sure all players report what version the game shows as they load the game or in the Credits section of the game. The reason to check here and not just ask if everyone applied the patch is that many players, including myself, install patches one level off where they should be applied. This will tell you it has actually been applied.

If you have checked that every is using the same or latest patch and you are still getting this error, and that you are getting an access violation report probably means you are not running the turn with administrative rights.
Try selecting run as admin and see if this fixes the problem.

If not, please report back.

Ekaton
Private
Posts: 33
Joined: Tue Oct 29, 2013 10:39 pm

Re: Game-breaking error

Sun Feb 25, 2018 1:17 pm

Admin's mode didn;t help, but the error log is longer this time.

1:13:52 PM (Reporting) Host: Starting AIs.
1:13:52 PM [Critical ] TGroup.PathExists Exception caught: 1011942 Burmese Army LogStep: 50 Access violation at address 00813967 in module 'PON.exe'. Read of address 0000045A
1:13:52 PM [Critical ] TGroup.PathExists Exception caught: 1011942 Burmese Army LogStep: 50 Access violation at address 00813967 in module 'PON.exe'. Read of address 0000045A
1:13:52 PM [Critical ] TGroup.PathExists Exception caught: 1011942 Burmese Army LogStep: 50 Access violation at address 00813967 in module 'PON.exe'. Read of address 0000045A
1:13:52 PM [Critical ] TGroup.PathExists Exception caught: 1014883 Column LogStep: 50 Access violation at address 00813967 in module 'PON.exe'. Read of address 0000045C
1:13:52 PM [Critical ] TGroup.PathExists Exception caught: 1014883 Column LogStep: 50 Access violation at address 00813967 in module 'PON.exe'. Read of address 0000045C

Ekaton
Private
Posts: 33
Joined: Tue Oct 29, 2013 10:39 pm

Re: Game-breaking error

Sun Feb 25, 2018 4:45 pm

Is it possible to somehow edit that Burmese army out? It's very minor.

Ekaton
Private
Posts: 33
Joined: Tue Oct 29, 2013 10:39 pm

Re: Game-breaking error

Mon Feb 26, 2018 3:38 pm

Is it possible to get a response?

User avatar
Nikel
Posts: 2378
Joined: Sun Apr 20, 2008 8:38 pm

Re: Game-breaking error

Mon Feb 26, 2018 4:09 pm

Waiting for an official answer...


Zip or rar the save, then it will be much smaller an you may upload it.


If still no answer you may try to edit the save file with a text editor and delete the Burma army.

No idea though, of any side issues the deletion may cause. Make a backup before.

Ekaton
Private
Posts: 33
Joined: Tue Oct 29, 2013 10:39 pm

Re: Game-breaking error

Mon Feb 26, 2018 9:13 pm


User avatar
Nikel
Posts: 2378
Joined: Sun Apr 20, 2008 8:38 pm

Re: Game-breaking error

Mon Feb 26, 2018 10:03 pm

Huge indeed. With ultra compression you may upload the file here, just in case they prefer it.


1850 GC0.7z
(1.55 MiB) Downloaded 30 times

User avatar
Pocus
Posts: 25231
Joined: Wed Oct 19, 2005 7:37 am
Location: Lyon (France)

Re: Game-breaking error

Tue Feb 27, 2018 11:16 am

The best course of action would be to have someone else try to run your turn, often what happens on a computer does not happen on another. If this fail, try editing out the army and associated units from the HST file, if it's not too big a loss.

Ekaton
Private
Posts: 33
Joined: Tue Oct 29, 2013 10:39 pm

Re: Game-breaking error

Tue Feb 27, 2018 3:21 pm

1. I've tried to delete the Burmese Army manually - the entire group and all subunits. Didn't work. It's no longer in the .hst file and searching "Burmese" only shows some events, but the army is still there on the map.
2. Tried it on another computer with the same version of PON, the same error occured.

Ekaton
Private
Posts: 33
Joined: Tue Oct 29, 2013 10:39 pm

Re: Game-breaking error

Tue Feb 27, 2018 3:32 pm

Amazingly, after the third attempt, it was possible to advance the turn using the French player. Previous attempts resulted in an indefinite black screen but right now it seems alright.

Return to “PON Technical Support / Aide Technique”

Who is online

Users browsing this forum: No registered users and 0 guests