User avatar
Hrothgar
Lieutenant
Posts: 114
Joined: Sat Aug 18, 2007 2:58 am

running very slowly

Sat May 13, 2017 2:34 am

Hi Folks,
I got the game and installed the patch, but the game is so slow that it's basically unplayable. Zooming in and out takes forever, cycling thru the stacks is like trying to run in molasses. Even trying to return to the main menu is a chore. I end up using Ctrl-Alt-Del to get to the task manager in order to exit the game. It's just not worth trying to play.

My specs: Acer Predator G6-710
Processor: i7-6700K CPU @ 4.00GHz
RAM: 16.0 GB
OS Win 10, 64bit

I have many other AGEOD Games, and have no trouble running them. Just to test, in case some recent problem affected my PC, I started Revolution Under Siege Gold, and it runs smoothly. I even fired up the biggest AGEOD game, Pride of Nations, and again, it runs well. Zooming is smooth, cycling units is quick, etc.

So, I don't think it's my system, since it's running other, larger, AGEOD games with no problems. I hope something can be done, because I've been looking forward to this one for a while.

Rodger

User avatar
Morgan
Private
Posts: 22
Joined: Sat Mar 18, 2017 3:10 pm
Location: North Carolina
Contact: Twitter

Re: running very slowly

Sat May 13, 2017 2:53 am

I've had the same problem, but not to the same extent. It is still playable, but it is significantly slower than the other games.

Also, I installed the game on my SSD, but I still hear the hard drive being used quite frequently. (My home directory is on the hard drive.) I see that the game is constantly writing logs to [home]\Documents\My Games\English Civil War\ECW. Perhaps there is debug code that is still enabled?

User avatar
jack54
Brigadier General
Posts: 445
Joined: Fri Jan 18, 2008 12:08 am
Location: East Tennessee USA

Re: running very slowly

Sat May 13, 2017 4:07 am

My main log is almost a GB... much bigger than any of my other Ageod games.

I wonder if writing to that log could be causing a slow down.

User avatar
Leibst
Posts: 2515
Joined: Wed Sep 27, 2006 6:06 am
Location: Madrid, Spain

Re: running very slowly

Sat May 13, 2017 7:37 am

Slitherine support team is analyzing this issue. During beta no one reported nothing similar. Be patient please I'm sure that we will find a solution. In theory this game should run faster as it has a small map compared to others.

HeinzHarald
Private
Posts: 20
Joined: Fri Sep 04, 2015 4:43 pm

Re: running very slowly

Sat May 13, 2017 9:13 am

I recommend making sure that error logging is off in options/system (unless you specifically want to check for errors of course), and to check task manager to see if it gives any hints.

For me the Windows 10 antimalware service was running red hot whenever the game was in focus (it used one full CPU core it seemed), even though I had added an exception for the Matrix Games folder (I ran borderless window smaller than my monitor and so could keep track of what happened). So I ended up adding an exception for ECW.exe too, that worked. However I can't really say how much of a difference this did in terms of actual performance, I noticed the issue while in the tutorial.

User avatar
Hrothgar
Lieutenant
Posts: 114
Joined: Sat Aug 18, 2007 2:58 am

Re: running very slowly

Sat May 13, 2017 1:19 pm

I'm not impatient. I understand that a just-released game can have undiscovered bugs. I simply wanted to let you know that, for me, the current problem renders the game unplayable.

I imagine that you folks will be able to fix it--as I said, I do not have this problem with any other AGEOD game, so it ought to be fixable. I can wait. I have plenty of other games to play. I just wanted to let you know that a serious problem exists right now, in the hopes that you would address it.

Looking forward to a solution.

p.s. Error logging is off, so that's not the problem. Also the save directory was set to OneDrive, and I changed that to save on the PC. However, that made no difference.

vaalen
AGEod Guard of Honor
Posts: 1142
Joined: Thu Dec 20, 2007 8:48 pm

Re: running very slowly

Sat May 13, 2017 3:17 pm

Leibst wrote:Slitherine support team is analyzing this issue. During beta no one reported nothing similar. Be patient please I'm sure that we will find a solution. In theory this game should run faster as it has a small map compared to others.


I bought this on faith, as I buy every Ageod game, the first day I can. I know you, and the fine work you have done, and I am confident you will find a solution, and soon.

I will wait to play the game until you fix it, as I know you will.

My sympathy for everyone who has suffered this problem, My long experience with AGEOD games has taught me that there is always a great game, a wonderful historical experience, beneath any bugs, and that game is worth the wait. Hopefully we will be able to see that game soon.

User avatar
PhilThib
Posts: 13416
Joined: Tue Oct 18, 2005 5:21 pm
Location: Meylan (France)

Re: running very slowly

Sat May 13, 2017 5:22 pm

Rest assured we shall follow the issue closely.

My 2cents about the issue is may in General.opt file, Log Batch section. I see that

// how many log lines should be written at once. Can slow down significatively the app & hosting if below 10.
LogBatch = 10

But in most other (faster) Ageod games, we have

// how many log lines should be written at once. Can slow down significatively the app & hosting if below 10.
LogBatch = 100


Try altering the file and changing the value to 100. :papy:

User avatar
jack54
Brigadier General
Posts: 445
Joined: Fri Jan 18, 2008 12:08 am
Location: East Tennessee USA

Re: running very slowly

Sat May 13, 2017 8:23 pm

Just in case anyone running slow is using Windows Defender; some users on matrix forum have had success by creating an exemption for ECW.

fthein
Corporal
Posts: 47
Joined: Tue Jun 09, 2015 5:32 pm

Re: running very slowly

Sat May 13, 2017 10:09 pm

PhilThib wrote:Rest assured we shall follow the issue closely.

My 2cents about the issue is may in General.opt file, Log Batch section. I see that

// how many log lines should be written at once. Can slow down significatively the app & hosting if below 10.
LogBatch = 10

But in most other (faster) Ageod games, we have

// how many log lines should be written at once. Can slow down significatively the app & hosting if below 10.
LogBatch = 100


Try altering the file and changing the value to 100. :papy:


Thanks. Did work for me. Now game scrolls very fast. :thumbsup:

User avatar
Hrothgar
Lieutenant
Posts: 114
Joined: Sat Aug 18, 2007 2:58 am

Re: running very slowly

Sun May 14, 2017 5:22 am

Changing that entry from "10" to "100" made a major difference. The game still is somewhat jerky compared to other AGEOD games, and rarely does a single mouse click register--it takes two or more clicks to get the interface to respond. But it's vastly better than it was.

I hope that the performance can be further improved. As has been noted in this thread, ECW is significantly smaller than most [all?] AGEOD games, so one would expect it to perform better. Making the suggested change in that file brings it within the bounds of playability, but still with significant annoyances from delays with the interface. Consequently, I hope that it will get better.

Thanks for the tip, though!

User avatar
Leibst
Posts: 2515
Joined: Wed Sep 27, 2006 6:06 am
Location: Madrid, Spain

Re: running very slowly

Tue May 16, 2017 10:26 pm

LogBatch = 250
recommended by Pocus. :papy:

Manassassas
Civilian
Posts: 4
Joined: Wed Oct 05, 2016 10:13 am

Re: running very slowly

Tue May 16, 2017 10:47 pm

PhilThib wrote:Rest assured we shall follow the issue closely.

My 2cents about the issue is may in General.opt file, Log Batch section. I see that

// how many log lines should be written at once. Can slow down significatively the app & hosting if below 10.
LogBatch = 10

But in most other (faster) Ageod games, we have

// how many log lines should be written at once. Can slow down significatively the app & hosting if below 10.
LogBatch = 100


Try altering the file and changing the value to 100. :papy:


This has also worked perfectly for me. I was getting really slow scroll speeds and unresponsive clicking before I changed the value. Works perfectly now. Thanks.

ldugmore
Civilian
Posts: 1
Joined: Sun Sep 11, 2016 8:33 pm

Re: running very slowly

Wed May 17, 2017 4:47 am

I was having the same problem with very sluggish responses after every mouse click. In the Options menu, my response times were around 60 to 90 seconds with the hard drive light solidly on. I tried changing the Log Batch parameter value from 10 to 100. I tried adding ECW.exe to the exclusions in Windows Defender.. no improvement. I uninstalled and reinstalled the game in a non \Program Files folder.. still nothing.

I finally solved the problem by stopping my WebRoot anti-virus. Everything worked great and looked beautiful UNTIL in turn 3 of the Naseby scenario during the turn resolution, I got ..

"Critical Error: Profiler.DLog:Error Accessing file. Sorry, the application will quit. Most probably this error occurred because your user account has no write access to the program directory. Please run the game with administrator rights."

I have full admin rights on my computer but just to test out the advice, I restarted the game with admin rights and it crashed again during the turn 3 resolution with the same error, so it's nothing to do with admin rights.

My computer:
Intel i7-4770K cpu @ 4.3Ghz
16GB memory
EVGA GeForce 1080 Ti graphics card
Mix of Samsung SSD's and WD Hard Drives
ASUS 27" monitor running at 2560x1440 (native resolution)
Windows 7 fully updated

Lindsay

Taillebois
Brigadier General
Posts: 499
Joined: Sat Nov 01, 2008 8:09 pm

Re: running very slowly

Wed May 17, 2017 5:57 am

I play on a really low spec laptop machine with 1.7 ghz and HD graphics and it works fine when I turn Windows Defender off. This makes it scroll OK. So I do this and turn Windows Defender back on when I want to go back to the internet etc.

There's a thread else where about this and you can make the ECW.exe an exception which is a better longer term solution.


I'm enjoying the game.

User avatar
Hrothgar
Lieutenant
Posts: 114
Joined: Sat Aug 18, 2007 2:58 am

Re: running very slowly

Wed May 17, 2017 12:47 pm

Thanks Leibst! Raising the LogBatch figure to 250 seems to have done the trick. The game appears to run comparably to other AGEOD games now.

HidekiTojo
Colonel
Posts: 305
Joined: Wed Apr 10, 2013 1:14 am
Location: Baltimore

Re: running very slowly

Tue May 23, 2017 1:43 am

So what do I need to change and why?

This game does run incredibly for me as well.

User avatar
Leibst
Posts: 2515
Joined: Wed Sep 27, 2006 6:06 am
Location: Madrid, Spain

Re: running very slowly

Tue May 23, 2017 5:32 am

In General.opt file, Log Batch section. I see that

// how many log lines should be written at once. Can slow down significatively the app & hosting if below 10.
LogBatch = 250


instead of LogBatch = 10


included in next patch.

Return to “English Civil War”

Who is online

Users browsing this forum: No registered users and 4 guests