al_infierno
Civilian
Posts: 2
Joined: Thu Nov 21, 2019 1:39 am

English Civil War started crashing on launch every time

Thu Nov 21, 2019 1:43 am

I was able to play English Civil War just fine a few days ago. Today, when I tried launching, it just freezes on the "War without an Enemy" screen indefinitely. Additionally, every other AGEOD game on my system now freezes on its own respective splash screen (CWII, TYW, Espana 1936 are what I tried). Not sure what happened as nothing changed with my system in terms of Windows updates or anything.

My specs are:

i7 6700k CPU
16 GB RAM
GTX 1070 (I've tried disabling the nVidia processes and nothing.)

Thanks.

User avatar
Durk
Posts: 2663
Joined: Thu Apr 28, 2011 4:36 am
Location: Wyoming

Re: English Civil War started crashing on launch every time

Fri Nov 22, 2019 3:04 am

Are you running as and administrator? That is one key, if so, what else to you see going on.

User avatar
Leibst
Posts: 2568
Joined: Wed Sep 27, 2006 6:06 am
Location: Madrid, Spain
Contact: Website Facebook

Re: English Civil War started crashing on launch every time

Fri Nov 22, 2019 5:20 pm

ALso check if there is no space on the hard drive. Sometimes that gives strange errors.

al_infierno
Civilian
Posts: 2
Joined: Thu Nov 21, 2019 1:39 am

Re: English Civil War started crashing on launch every time

Sat Nov 23, 2019 9:44 pm

Thanks for the responses guys. I think the issue was not enough SSD space. I had about 20 GB free and ended up clearing about ~100, and now the game seems to run fine. ;)

Return to “English Civil War”

Who is online

Users browsing this forum: No registered users and 1 guest