02Pilot
Private
Posts: 26
Joined: Sat Nov 10, 2007 5:49 pm

Anyone get PoN running on Linux yet?

Tue Jun 07, 2011 2:15 pm

I used the instructions posted for RoP by andatiep ( http://www.ageod-forum.com/showthread.php?t=17146 ), since they were the most recent I could find. I'm running Ubuntu Natty with the Wine package from the Ubuntu Software Center, which includes Winetricks. The game installed OK, but after what appears to be an almost full load sequence, it crashes with the following:

Exception EExternalException dans le module ntdll.dll dans 0002E198. Exception externe C0000025.

and then:

Exception EAccessViolation dans le module PON.exe dans 00006E84. Violation d'acces a l'adresse 00406E84 dans le module 'PON.exe'. Lecture de l'adrresse 00000004.

I'm not too well-versed on the use of Wine under Linux, so if anyone has ideas about how to fix this, I'm all ears. Thanks.

marcusjm
Colonel
Posts: 321
Joined: Sun Jul 08, 2007 1:40 am
Location: Gothenburg/Sweden

Tue Jun 07, 2011 2:17 pm

I got it running on ipad though ;)

User avatar
helm123
Private
Posts: 38
Joined: Wed Apr 18, 2007 11:24 am
Location: Virginia

Wed Jun 08, 2011 2:53 am

Haven't purchased PON yet, But CitizenX has a very good step by step here (lastpost)

http://www.ageod-forum.com/showthread.php?t=10201&highlight=linux

It has worked for everyone of the ageod titles so far.

the_dovlets
Private
Posts: 31
Joined: Tue Dec 07, 2010 10:11 pm

Wed Jun 08, 2011 4:04 am

Hello

I can get the game to start under Natty Narwhal and I can play scenarios but not the great campaign.
Other AGE engine games such as Rise of Prussia or Revolution under Siege work fine on my Linux laptop, though

Everytime I start the Great Campaign the game engine displays an error after displaying the map. These are the critical messages from the game log

1:57:51 PM [Critical ] TParticlesDef.Fetch Data container for particles definitions has some discrepancies, for UID 1

02Pilot
Private
Posts: 26
Joined: Sat Nov 10, 2007 5:49 pm

Thu Jun 09, 2011 2:23 am

Tried CitizenX's method, but no dice; same error as before. I really wish I knew more about this stuff so I could contribute rather than simply failing and then begging for help....

User avatar
helm123
Private
Posts: 38
Joined: Wed Apr 18, 2007 11:24 am
Location: Virginia

Thu Jun 09, 2011 3:17 am

Got the same error. Might try looking at it in a couple days.

User avatar
helm123
Private
Posts: 38
Joined: Wed Apr 18, 2007 11:24 am
Location: Virginia

Sat Jun 11, 2011 6:27 pm

OK. Found something interesting here.

When starting up the game and selecting the grand campaign I also receive the UID error. But mine seems to always be UID3 which I believe from looking in the particles folder that corresponds to the railroad file.

No errors pop in the command line for wine except a couple fixme's.

So to start trying to troubleshoot this i open up the mainlog file for PON and fire up one of the scenarios. Watching what happens for particles. I can see that four particle files were loaded fine.

Next I quit the current scenario and start a new scenario and I notice via the log file that no particle files are loaded. This makes me wonder if they are already loaded in memory.

SO as a test I start up the grand campaign as Japan. Behold no errors and the grand campaign loads.

Haven't really tested much more that that so far.

Ran another test. This time as the USA. The campaign appeared to start fine. But as soon as I zoomed in on the USA land it crashed.

Return to “Pride of Nations”

Who is online

Users browsing this forum: No registered users and 3 guests